Вход | Регистрация
 

8.3 Не срабатывает оповещение

8.3 Не срабатывает оповещение
Я
   illiona
 
04.08.20 - 09:58
Добрый день. Не срабатывает оповещение. Режим запуска обычное приложение
&НаКлиенте
Процедура ВыбратьДокументПоступления()
    
    СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров(
        ЭтотОбъект, Объект, Новый ОписаниеОповещения("ПослеВыбораДокументаПоступления", ЭтотОбъект));
    
КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры) Экспорт
КонецПроцедуры
   lucbak
 
1 - 04.08.20 - 10:10
(0) Для обычного приложения есть небольшой ньюанс при использовании "оповещения" а именно необходимо процедуру оповещения расположить еще и в модуле объекта.
   illiona
 
2 - 04.08.20 - 10:13
(1) попробую, просто повторить в модуле процедуру ПослеВыбораДокументаПоступления?
   lucbak
 
3 - 04.08.20 - 10:24
(2) да, в модуле объекта
   lucbak
 
4 - 04.08.20 - 10:26
(3) причем процедуру можно просто пустую вставить (без кода внутри)
   illiona
 
5 - 04.08.20 - 14:14
(4) Все равно не получилось(
   lucbak
 
6 - 04.08.20 - 15:32
(5) Покажи как написал код в модуле объекта и в модуле формы?
   ZDenis
 
7 - 04.08.20 - 15:39
Может я что-то не понимаю, но если "Режим запуска обычное приложение" - то форма то какая открывается?
   lucbak
 
8 - 04.08.20 - 16:05
(7) В обычном приложении никто не мешает открывать управляемые формы.
   ZDenis
 
9 - 04.08.20 - 16:09
(8) Как это?
   ДенисЧ
 
10 - 04.08.20 - 16:26
(9) Как обычную. Если она в конфигурации, а не внешняя
   ZDenis
 
11 - 04.08.20 - 16:29
(10) что-то никогда так не пробовал делать. И что откроется прямо эта форма с ее процедурами или как если бы у объекта не было назначенных форм?
   ДенисЧ
 
12 - 04.08.20 - 16:44
(11) Откроется нормальная управляемая форма.
Ща пример покажу
   ДенисЧ
 
13 - 04.08.20 - 16:48
http://pics.wfido.ru/img/frm_vtbvi.png

Это управляемая форма в обычном приложении.
   ZDenis
 
14 - 04.08.20 - 16:57
(13) Ха, точно. Попробовал сейчас в ЗУП 2.5 управляемые формы позапускать. Вот же. Никогда бы не подумал
   polosov
 
15 - 04.08.20 - 17:07
(0) Не пробовал внимательно читать СП по ОткрытьФорму?
   polosov
 
16 - 04.08.20 - 17:08
(0) Оповещай сам, короче.
   illiona
 
17 - 05.08.20 - 06:00
(6)
Это в документе на форме
&НаКлиенте
Процедура ВыбратьДокументПоступления()
    СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров(
        ЭтотОбъект, Объект, Новый ОписаниеОповещения("ПослеВыбораДокументаПоступления", ЭтотОбъект));
КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры) Экспорт
    Если ЗначениеЗаполнено(ВыбранныйДокумент) Тогда
        Если ИнтеграцияМДЛПВызовСервера.ЕстьРасхожденияМеждуУведомлениемИОснованием(Объект.Ссылка, ВыбранныйДокумент) Тогда
            ДополнительныеПараметрыВопроса = Новый Структура;
            ДополнительныеПараметрыВопроса.Вставить("ДокументПоступления", ВыбранныйДокумент);
            Обработчик = Новый ОписаниеОповещения("ОбработатьОтветОРасхождениях", ЭтотОбъект, ДополнительныеПараметрыВопроса);
            ТекстВопроса = НСтр("ru='В уведомлении есть товары которых нет в выбранном поступлении. Продолжить выбор?'");
            ПоказатьВопрос(Обработчик, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
        Иначе
            ОбработатьВыборДокументаПоступления(ВыбранныйДокумент);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

В модуле этого же документа
&НаКлиенте
Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры)
КонецПроцедуры
   ДенисЧ
 
18 - 05.08.20 - 06:22
Может СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров кривая?

ЧТо там в ней? ИЛи она закрыта?
   illiona
 
19 - 05.08.20 - 06:30
Процедура ОткрытьФормуВыбораДокументаПоступлениеТоваров(Форма, Объект, ОповещениеПриЗавершении) Экспорт
    ОткрытьФорму("Документ.ПоступлениеТМЦ.ФормаВыбора",,Форма,,,,ОповещениеПриЗавершении);
КонецПроцедуры
   ДенисЧ
 
20 - 05.08.20 - 06:32
(19) Вроде нормально. Может ФормаВыбора кривая? Не оповещает о выборе?
   illiona
 
21 - 05.08.20 - 06:33
а что в форме выбора прописать?
   ДенисЧ
 
22 - 05.08.20 - 06:35
Форма (Form)
ОповеститьОВыборе (NotifyChoice)
Синтаксис:
ОповеститьОВыборе(<ЗначениеВыбора>)
Параметры:
<ЗначениеВыбора> (обязательный)
Тип: Произвольный.
Результат выбора.
Описание:
Посылает оповещение владельцу формы о выполнении выбора или подбора, передает ему выбранное значение. Закрывает форму в соответствии со значением свойства ЗакрыватьПриВыборе. Данное действие аналогично выполнению выбора в форме, открытой для выбора в поле ввода или ячейке табличного поля.
Доступность:
Толстый клиент.
Примечание:
Может применяться в случае, когда открытие формы выбора или подбора выполнено средствами языка.
Пример:
ОповеститьОВыборе(ТекущаяСтрока);
См. также:
Форма, событие ОбработкаВыбора
Использование в версии:
Доступен, начиная с версии 8.0.
     Методическая информация
   illiona
 
23 - 05.08.20 - 12:03
(20) не оповещает, даже в функцию не заходит оповещание выбора
   polosov
 
24 - 05.08.20 - 13:34
(23) см (15)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.