Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работающие фоновые задания

Работающие фоновые задания
Я
   AntonU
 
04.08.20 - 14:44
Всем добрый день.
Появилась задача получать программно список работающих в данный момент фоновых заданий. Программа на 8.3
Посоветуете, как это реализовать?
   aleks_default
 
1 - 04.08.20 - 14:49
Посмотри консоль заданий например. И вообще почитай в синтаксис помощнике про менеджер фоновых заданий
   AntonU
 
2 - 04.08.20 - 14:53
пока такой вариант

    ТекДата=ТекущаяДата();
    Фоновые = ФоновыеЗадания.ПолучитьФоновыеЗадания();
    
    Для Каждого Фоновое из Фоновые Цикл
        
        РегламентноеЗадание = Фоновое.РегламентноеЗадание;
        Если РегламентноеЗадание <> Неопределено Тогда
            
            Если РегламентноеЗадание.Начало>=ТекДата И РегламентноеЗадание.КонецБ=ТекДата Тогда
                
                Сообщить (РегламентноеЗадание.Наименование);
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;
   aleks_default
 
3 - 04.08.20 - 15:09
ПолучитьФоновыеЗадания(Отбор!)
   AntonU
 
4 - 04.08.20 - 15:25
Отбор.Вставить ("Состояние", СостояниеФоновогоЗадания.Активно);

Спасибо большое

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.