Вход | Регистрация
 

НайтиПоСсылкам показывает объекты, в которых саму ссылку найти не могу. Как так-то?

НайтиПоСсылкам показывает объекты, в которых саму ссылку найти не могу. Как так-то?
Я
   Галахад
 
06.08.20 - 09:43
МассивСсылок = Новый Массив;
МассивСсылок.Добавить(МояСсылка);
ТаблицаСсылок = НайтиПоСсылкам(МассивСсылок);

Смотрю и вижу несколько документов "Передача товаров между организациями"

Окай. Открываю документы и не вижу ничего похожего на МояСсылка.
Окай. Смотрю запросом. Не вижу.
Окай. Написал немного коду:

Для Каждого Рек Из Док.Метаданные().Реквизиты Цикл
    
    Если Рек = РекДляПоиска Тогда
        Сообщить(Рек.Имя);
    КонецЕсли;
    
КонецЦикла;

Для Каждого ТЧ Из Док.Метаданные().ТабличныеЧасти Цикл
    
    Для Каждого Рек Из ТЧ.Реквизиты Цикл
        Если Рек = РекДляПоиска Тогда
            Сообщить(Рек.Имя);
        КонецЕсли;
    КонецЦикла;
    
КонецЦикла;

И снова ничего.

Кто виноват? Что делать?
   Галахад
 
1 - 06.08.20 - 09:45
О, млин. Тема закрыта.
   Галахад
 
2 - 06.08.20 - 09:52
Хотя нет. Переписал так:
Для Каждого Рек Из Док.Метаданные().Реквизиты Цикл
    
    Если Док[Рек.Имя] = РекДляПоиска Тогда
        Сообщить(Рек.Имя);
    КонецЕсли;
    
КонецЦикла;

Для Каждого ТЧ Из Док.Метаданные().ТабличныеЧасти Цикл
    
    Для Каждого Рек Из ТЧ.Реквизиты Цикл
        
        Для Сч = 0 По Док[ТЧ.Имя].Количество() - 1 Цикл
            а = Док[ТЧ.Имя][0][Рек.Имя];
            Если а = РекДляПоиска Тогда
                Сообщить(Рек.Имя);
            КонецЕсли;
        КонецЦикла;
        
    КонецЦикла;
    
КонецЦикла;

Все равно не нашёл...
   Вафель
 
3 - 06.08.20 - 10:21
движения?
   Вафель
 
4 - 06.08.20 - 10:22
хотя у тебя в коде сч не используется
   Волшебник
 
5 - 06.08.20 - 10:30
Найден один документ, а проверяешь другой
   Fedor-1971
 
6 - 06.08.20 - 10:34
(2) Очень похоже, что не так перебираешь, тебе нужны типы данных,
т.е. что-то примерно такого: Док[Рек.Имя].ОписаниеТипов.Содержит(ТипЗнч(МояСсылка))

по сути, сделай запрос с выводом всех реквизитов и ТЧ найденных документов (получится такая одуренная таблица), выгрузи оную в MXL и поищи обычным поиском по части представления ссылки
   RomanYS
 
7 - 06.08.20 - 10:46
(2) Движения и последовательности - по факту живут в отдельных таблицах, но поиск по ссылкам показывает как будто ссылка в регистраторе.
   Галахад
 
8 - 06.08.20 - 12:32
Спасибо. Действительно движения.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.