Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

вместо 6 создает 36 документов

↓ [Волшебник, 23.10.20 - 12:42]
вместо 6 создает 36 документов
Я
   Snail
 
23.10.20 - 10:32
ТЗ = Новый ТаблицаЗначений;        
    ТЗ = Объект.ВФ.Выгрузить();
    
    КоличествоКолонок = ТЗ.Колонки.Количество();
    Для КК = 3 По КоличествоКолонок -1 Цикл    
        Если ТЗ.Итог(КК) = 0 Тогда
            Продолжить;
        КонецЕсли;
        Если  ТЗ.Итог(КК) <> 0 Тогда            
            Для  СтрокаДаных = 2 По ТЗ.Количество() Цикл                
                Если ТЗ.Итог(СтрокаДаных) = 0 Или СтрокаДаных = 2 Тогда
                    Продолжить;
                Иначе
                    НовыйДокумент = Документы.Пробный.СоздатьДокумент();    
                    НовыйДокумент.Дата = ТекущаяДата();                        
                    Для Каждого Строка Из ТЗ Цикл  
                        Стр = НовыйДокумент.ТЧПробного.Добавить();
                        Стр.Номенклатура = Справочники.ГП.НайтиПоРеквизиту("КодЗагрузкиГП", Строка.Колонка2);
                        Стр.Количество = Строка[КК];    //Колонка4;                     
                    КонецЦикла;        
                    НовыйДокумент.Записать();            
                КонецЕсли;    
            КонецЦикла;            
        КонецЕсли;    
    КонецЦикла;
   Snail
 
1 - 23.10.20 - 10:35
Все, нашел )
   Snail
 
2 - 23.10.20 - 10:36
НовыйДокумент.Записать();         не туда впихнул
   Галахад
 
3 - 23.10.20 - 10:40
Млин, какой сложночитаемый код.

Пожалуй нужно сюда Конструктора1С, для лекции. ))
   Snail
 
4 - 23.10.20 - 10:42
Галахад, я только учусь )
   Snail
 
5 - 23.10.20 - 10:43
Я сейчас его оформлю нормально
   Mikeware
 
6 - 23.10.20 - 10:45
(4) учатся немножко не так...
учатся - это запускают отладчик, и смотрят...
   Сергиус
 
7 - 23.10.20 - 12:16
(6)Миста лучший отладчик!)
   Mikeware
 
8 - 23.10.20 - 12:17
(7) да, забыл...
   Snail
 
9 - 23.10.20 - 12:18
Еще вопрос:

НовыйДокумент.Контрагент = Справочники.Контрагенты.НайтиПоРеквизиту("КодЗагрузки",ТЗ[1][3]);

В справочнике реквизит КодЗагрузки = 546 (число)
Если Сообщить(ТЗ[1][3]) выдает 546
Почему при создании документа не заполняет объект.контрагент?
   Builder
 
10 - 23.10.20 - 12:36
(9) Не заполняет - значит не находит.
Вообще принято после поиска проверять нашлось что или нет.
Ну и неплохо бы явно преобразовывать типы к нужному, строка-> число например.
   Snail
 
11 - 23.10.20 - 12:38
Спасибо, точно перепутал типы значений

Список тем форума
Рекламное место пустует  Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.