Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отключить - Это копия информационной базы

Отключить - Это копия информационной базы
Я
   Grogan
 
17.06.21 - 00:22
Доброго здоровьеца!

Есть внешняя обработка, в коде которой надо прописать закрытие вот этого окошка:
https://prnt.sc/15mzwnk

Оно появляется если база восстановлена из бэкапа. Вопрос-подскажите направление куда копать? Пробовал сделать с помощью нажатий на кнопки:

Shell=Новый COMОбъект("Wscript.Shell"):
Shell.SendKeys("{ESC}");
и тд.

Но при тестах все работает, а при запуске в автомате, не отрабатывает. Вообщем надо как то программно закрыть. Спасибо!
   RomaH
 
1 - 17.06.21 - 06:31
параметры запуска не помогут?

исправить текст программы не вариант?
   ribuh
 
2 - 17.06.21 - 06:45
Администрирование - Обслуживание - Регламентные операции - там большая кнопка "Разблокировать работу с внешними ресурсами"
   Почему 1С
 
3 - 17.06.21 - 06:55
А для чего стоит такая задача? Если для проведения сценарных тестов, то через них и закрыть это окно при их запуске
   DrZombi
 
4 - 17.06.21 - 07:52
(0) Зачем вы на другом ПК запускаете копию базы и при этом почему-то пытаетесь кнопку нажимать ботом...
При этом нажимать на "ESC", вместо того, что бы нажать на нужную кнопку, вызвав команду мышки... :)

А можно же и поправить интерфейс и прописать у "1С Формы обработки" горячую клавишу...

...
А так, как тут вам советуют, вы можете вообще таки отключить появление этого окна, даже написать свой обработчик.
Можно же при запуске клиента 1С, так же передавать командную строку, где бы была прописана ваша команда, по которой в свою очередь обработчик бы понимал, что от него хотят.

...А так все это чревато последствиями, параметр "Это копия" всего лишь останавливает обмены в БД и все...
...другие регламентные задания оно не тормозит...
...И если вы прописали чего важного - "К примеру чтения почты" или "Поместить товар на сайт компании"... То это все писанное вами будет обработано...


Пример, как я запрещаю обработкам работать в копиях... По регламентным заданиям (бывает, что надо даже в копии запускать регламентные, но не надо, что бы они отработали)

//Просто условие...

Если БлокировкаРаботыСВнешнимиРесурсами.РаботаСВнешнимиРесурсамиЗаблокирована() = Истина Тогда
    //Заблокируем выполнение обработки

     Возврат;
КонецЕсли;
   DrZombi
 
5 - 17.06.21 - 07:56
+//....

Функция РаботаСВнешнимиРесурсамиЗаблокирована() Экспорт
    
    Возврат ПараметрыСеанса.РаботаСВнешнимиРесурсамиЗаблокирована;
    
КонецФункции
   Grogan
 
6 - 17.06.21 - 08:31
DrZombi, спасибо! Буду пробовать.

Окошко нужно закрыть чтобы пользователям не мешало и меньше вопросов было. Обращаюсь, потому как не являюсь матерым программистом(только хочу им стать) и всех возможностей не знаю они для меня далеко не очевидны на текущий момент.
   Йохохо
 
7 - 17.06.21 - 08:37
(6) важно, вы в копию восстанавливаете или в рабочую? если в рабочуую все не так
   Grogan
 
8 - 17.06.21 - 08:39
в копию
   ДенисЧ
 
9 - 17.06.21 - 08:52
(6) Чтобы у пользователей не возникало вопросов - заходи в восстановленную базу первым и нажимай сам.
   Serg_1960
 
10 - 17.06.21 - 09:44
PS: не важно кто и как будет "отключать" окошко, - важно, чтобы по окончании всех манипуляций с копией базы, было /AllowExecuteScheduledJobs -Off
   1Сергей
 
11 - 17.06.21 - 10:47
(9) Вот у нас скриптами создается автокопия "на вчера". Но, проблему в (0) так и не решил. Сказал что это фича
   Grogan
 
12 - 17.06.21 - 11:26
Чтобы у пользователей не возникало вопросов - заходи в восстановленную базу первым и нажимай сам.   ---- спасибо за совет, но я тему как раз создал чтоб этого не делать) И вообще забыть про эту базу. Восстановилась, обработка запустилась, закрыла окошко и все.
   1Сергей
 
13 - 17.06.21 - 11:39
(12) на самом деле, это не проблема что при первом запуске пользователь увидит это окошко
   vs7719
 
14 - 17.06.21 - 12:29
Если у пользователя убрать права администратора, то данное окно не будет появляться.
   Grogan
 
15 - 21.06.21 - 02:30
Попробовал запустить с дополнительными параметрами  /AllowExecuteScheduledJobs -Off  , окошко не убралось.


Это:

Функция РаботаСВнешнимиРесурсамиЗаблокирована() Экспорт
    
    Возврат ПараметрыСеанса.РаботаСВнешнимиРесурсамиЗаблокирована;
    
КонецФункции

тоже не помогло. Хз что делать, разбираюсь с autohotkey скриптами. Думаю с их помощью победить
   DrZombi
 
16 - 21.06.21 - 08:15
(15) Мил человек.

"РаботаСВнешнимиРесурсамиЗаблокирована" - Только Регламентов, вызываемых из обработки или еще как "По вашим доработкам"
"/AllowExecuteScheduledJobs -Off" - Только для БОТА... в основном.

Вам же, надо убрать это модальное окно, что вам надо сделать:
1. Найти в 1С, то место, откуда вызывается данный диалог, и выпилить его совсем из программы. (что чревато другими проблемами)
2. Настроить всем пользователям, нормальные права доступа, Данное окно открывается только пользователю с ролью "Полные права" (очень странно, что вы всем дали полные права на копию базы)
3. Будь мужиком, зайди один раз в БД и нажми "Это копия"
4. Будь Программистом, и наконец настрой БОТА - Обработку, которая будет отрабатывать и сама устанавливать в программе нужную константу или регистр в нужное значение, что бы как бы эмулировалось нажатие на кнопку "Это копия"
   Смотрящий от 1С
 
17 - 21.06.21 - 14:29
Поиском по конфигурации ищем "Это копия". Находим ОМ "БлокировкаРаботыСВнешнимиРесурсами". Там минимум сложности чтобы отключить все окошки
   1Сергей
 
18 - 21.06.21 - 14:43
(17) не ломая конфу сложно
   Krendel
 
19 - 21.06.21 - 15:40
Я конечно не эксперт, но мне казалось что эта фигня отключается в настро1ках
   Grogan
 
20 - 17.07.21 - 22:54
Решилось с этим окошком просто все:

БлокировкаРаботыСВнешнимиРесурсами.ЗапретитьРаботуСВнешнимиРесурсами(); 


Спасибо за помощь!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.