Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ошибка Тип не определен (КонструкторСхемыКомпоновкиДанных)

Ø [Волшебник, 15.09.21 - 10:56]
ошибка Тип не определен (КонструкторСхемыКомпоновкиДанных)
Я
   VID1234
 
15.09.21 - 10:00
Здравствуйте. Подскажите, почему при открытии отчета на толстом клиенте, все норм, а при открытии на тонком клиенте пишет: {ОбщаяФорма.ФормаОтчета.Форма(751,22)}: Тип не определен (КонструкторСхемыКомпоновкиДанных), что это может быть?
   ДенисЧ
 
1 - 15.09.21 - 10:01
Потому что нефиг НаКлиенте компоновку крутить.
   Волшебник
 
Модератор
2 - 15.09.21 - 10:01
в тонком клиенте нет типа КонструкторСхемыКомпоновкиДанных
   VID1234
 
3 - 15.09.21 - 10:08
(2) Здравствуйте. А что сделать то? Я создал в конфигураторе внешний отчет и там создал отчет на основе СКД, как быть в таком случае?
   VID1234
 
4 - 15.09.21 - 10:10
(1) Здравствуйте. Так у меня формы нет вообще!
   ДенисЧ
 
5 - 15.09.21 - 10:11
(3) (4) Значит, конфигурация не типовая и уже кто-то её поломал.
Потому что у меня в нетиповой бухии с несломанной подсистемой отчётов таких проблем нет.
   VID1234
 
6 - 15.09.21 - 10:12
(5) Ну да, не типовая!
   youalex
 
7 - 15.09.21 - 10:16
(4) ОбщаяФорма.ФормаОтчета - этой формы у тебя нет?
   VID1234
 
8 - 15.09.21 - 10:17
(7) Здравствуйте. Эта форма есть, я про форму в СКД отчете, там нет формы!
   youalex
 
9 - 15.09.21 - 10:35
(8) А на закладке Формы, в поле "Форма отчета" у тебя что?
   VID1234
 
10 - 15.09.21 - 10:39
(9) Ничего! у меня нет формы
   VID1234
 
11 - 15.09.21 - 10:39
Вопрос решен, добавил это:
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
Настройки.ФормироватьСразу = Истина;
Настройки.События.ПриСозданииНаСервере = Истина;
КонецПроцедуры

Процедура ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
ОбъектыНазначения = ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(Форма.Параметры, "ОбъектыНазначения");
Если ОбъектыНазначения <> Неопределено Тогда
Форма.ФормаПараметры.УстановитьЗанчениеПараметра("Регистратор", ОбъектыНазначения);
КонецЕсли;
КонецПроцедуры
 и все заработало!
   Гений 1С
 
12 - 15.09.21 - 10:39
(0) запускай в толстом клыенте
   Гений 1С
 
13 - 15.09.21 - 10:42
(10) там форма по умолчанию используется.
открой ОбщаяФорма ФормаОтчета Форма и посмотри строку 751
если что, замени Новый КонструкторСхемыКомпоновкиДанных на вычислить("Новый КонструкторСхемыКомпоновкиДанных()")

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.